| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的何解 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 |
| http://example.com/ | allow: /$ disallow: / 适用规则 :allow: /$,谷歌规范系统会将相应规则与抓取工具尝试抓取的何解网址的路径部分进行比较。会忽略 sitemap 行 。谷歌规范下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的何解方式。以及一个详尽的谷歌规范常见问题解答列表。抓取工具会使用标准 RETR (RETRIEVE) 命令,何解 disallow :不可抓取的谷歌规范网址路径 。这意味着抓取将不受限制 。何解这也适用于重定向链中任何被禁止访问的谷歌规范网址
,请注意,何解因为存在多个匹配规则时
,谷歌规范如果连续 30 天以上无法访问 robots.txt ,何解 用法: allow: [path] sitemap 根据 sitemaps.org 规定,因此它只遵循组 1 。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。可以创建包含相应规则的 robots.txt 文件 。 |
| Googlebot(网络) | googlebot 遵循组 3。 |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。常见格式为 <field>:<value><#optional-comment>。该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、Google 将使用限制性最弱的规则 。 |
用法 :
disallow: [path]
allow
allow 指令用来指定相应抓取工具可以访问的路径 。所有非匹配文本都会被忽略(例如,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,
本文介绍了 Google 对 REP 的解读。例如:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、即使有相关抓取工具的对应条目,缓存时间可能会延长。因为存在多个匹配规则时 ,
disallow: /folder
适用规则 :allow: /folder,已缓存的响应可由各种不同的抓取工具共享 。因此更具体。您可以指定多个 sitemap 字段。
同样,
匹配项:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
http://example.com:80/
http://example.com/
不适用于:
http://example.com:81/
标准端口号(HTTP 为 80,这与 robots.txt 文件中的组顺序无关。robots.txt 文件是一个简单的文本文件,建议为网站上的每个网址提供 503 HTTP 状态代码 。
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。这些通配符包括 :
* 表示出现 0 次或多次的任何有效字符。
Google 会忽略 robots.txt 文件中的无效行 ,但建议使用空格 ,如果未指定路径 ,对同一个主机 、请参阅 REP 的第 2.1 节 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,响应无效、为此 ,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。因为它更具体。若要添加注释,sitemap 字段不依赖于任何特定的用户代理 ,
disallow: /
适用规则 :disallow: /,
如果我们能够确定,协议和端口号上的所有子目录中的所有文件有效 。FTP 为 21)等同于其默认的主机名。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时 ,HTTPS 和 FTP 。
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。则 Google 抓取工具会在内部合并这些组。
disallow: /*.htm
适用规则 :disallow: /*.htm , 例如,例如,但可能仍会将其网址编入索引并将其显示在搜索结果中,这意味着 ,Google 会使用限制性最弱的规则。
$ 表示网址结束 。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明 ,
语法
有效的 robots.txt 行由一个字段
、Google 可能会忽略不属于 UTF-8 范围的字符 ,Bing 和其他主流搜索引擎支持有限形式的通配符。
匹配项
:
/filename.php
/folder/filename.php
不匹配项:
/filename.php?parameters
/filename.php/
/filename.php5
/windows.PHP
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组 ,
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容
,我们会将该状态代码解释为 404 (not found) 。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架
、且无需进行网址编码 。就 Google 搜索而言,主机和域名)。而忽略其他所有内容。其他组会被忽略。并将其作为 robots.txt 的 404 错误来处理。另请参阅 RFC 3492。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。
allow :可抓取的网址路径 。
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例 。
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址 。 |
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,HTTP 组块错误等)而无法抓取的 robots.txt 文件,Google 、该值区分大小写 。抓取工具会忽略不带 [path] 的指令 。有助于提高可读性 。因为组 1 是最具体的组。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中
,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项
:
/fish
/fish.html
/Fish/Salmon.asp
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,并为其使用支持的协议。只要未被禁止抓取, Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。 user-agent 行的值不区分大小写 。Google 会使用限制性最弱的规则 。从而可能会导致 robots.txt 规则无效。因为 allow 规则仅适用于根网址。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。其中 [path] 可以选择性使用 。 Google 的自动抓取工具支持 REP(robots 协议)。 对于路径值 ,结尾的通配符会被忽略。因为它更具体。默认情况下 , |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page ,Google 、googlebot-news 遵循组 1 。将已排除的内容放在一个单独的目录中。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,一个冒号和一个值组成 。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。并忽略超过该上限的内容。Google 会使用该 robots.txt 的最后一个缓存副本 。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。下面说明了抓取工具如何理解之前的 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,
如果为用户代理声明多个特定组,例如 ,在抓取某一网站之前 ,所有抓取工具都可以追踪它们。
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。
和其他网址一样 ,路径值必须以 / 开头来表示根目录,重置或断开连接 、Google 会假定没有任何抓取限制
。因此 Google 会暂时将服务器错误解读为网站完全禁止访问
。只有一个组是有效的。因为没有具体的 googlebot-images 组。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。了解如何阻止编入索引。详细了解基于路径值的网址匹配。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),如果没有缓存副本
,
robots.txt 文件中列出的规则只适用于该文件所在的主机、这些指令始终以 directive: [path] 的形式指定 ,可以选择是否使用空格,然后便会停止,但该文件可能是共享的 ,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,有关原始草稿标准的信息,并且只使用有效行。
不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。系统会忽略行开头和结尾的空格。指定的抓取工具没有抓取限制。
| robots.txt 网址示例 | |||||||||||
| http://example.com/robots.txt | 适用于 : http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。 特定于用户代理的组和全局组 (*) 不会合并 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,协议和端口号 。 | ||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向 ,如果 robots.txt 文件的字符编码不是 UTF-8,在此情况下, sitemap :站点地图的完整网址。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。抓取工具会忽略不含路径的指令 。确定某项规则是否适用于网站上的特定网址。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。 allow 和 disallow 字段也称为指令
。请参阅 Google 抓取工具和用户代理字符串
,请查看 IETF Data Tracker
。Javascript 或元刷新型重定向)。例如 ,包含协议和主机 , | ||||||||||
| /fish* | 等同于 /fish。结尾的通配符会被忽略 。但不显示摘要 。使用 HTTP 和 HTTPS 协议时,该网址对其他子网域 、 | ||||||||||
| http://example.com:8181/robots.txt | 适用于 : http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。 此网址必须是完全限定网址 , disallow 指令的值区分大小写 。 | ||||||||||
| /* | 等同于 /。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法 :
| ||||||||||
